코스모스팜 스레드

게시판 줄바꿈 태그가 사라지고, [미디어 추가] 버튼 클릭 시 반응이 없습니다.

안녕하세요.

 

1. 게시판 글 수정 시 줄바꿈했던 것이 삭제됩니다.

글 쓰기할 때 엔터를 치면  가 삽입되고, 바로 저장하면 줄바꿈이 적용됩니다.

그런데 글 수정으로 들어가면 모두 삭제되어 있습니다.

<br /> 태그는 입력해도 적용이 안되구요.

 

얼마 전에 저와 같은 이슈의 문의가 있었네요.

https://www.cosmosfarm.com/threads/document/23203

 

 

2. [미디어 추가] 버튼 클릭 시 아무런 반응이 없습니다;

테스트용 관리자 아이디를 이메일로 보내드릴테니, 확인이 가능하실지요?

감사합니다.

코스모스팜 회원관리
코스모스팜 회원관리
  • 안녕하세요~^^

    우선 몇 가지 확인을 먼저 해주시겠어요?

    1. 디버그 모드를 활성화해서 어떤 오류를 표시하는지 확인해보세요.

    워드프레스 에러 확인하기 - 디버그 모드 활성화 방법

    2. 테마의 문제일 수도 있으니 잠시 다른 테마로 바꿔서 확인해보세요.

    3. 다른 플러그인을 모두 비활성화한 후에 충돌이 있는지 확인해보세요.

    4. 현재 사용 중이신 KBoard 게시판 플러그인의 버전이 어떻게 되시는지요?

    최신 버전으로 업데이트하신 후에 다시 확인해보시겠어요?

     

    위의 방법으로도 해결이 되지 않으신다면

    저희 고객지원 쪽 이메일로 워드프레스 계정과 FTP 접속 정보 보내주시면 점검해드리겠습니다.

    고맙습니다.

  • 답변 감사합니다.

     

    1. 오류코드가 올라오긴 하지만 어떤 에러인지는 잘 모르겠습니다.

    마지막 오류코드
    PHP Warning: Invalid argument supplied for foreach() in /idia0/www/idia/wp-content/themes/enfold/framework/php/class-framework-widgets.php on line 3030

    2. 다른 테마(Bridge)로 바꾸었을 때, [미디어 추가] 버튼은 정상적으로 작동합니다. Enfold 테마에서만 문제가 있는 듯 합니다.

    3. 비활성화해 보아도 같은 현상입니다.

    4. 5.3.8에서 5.3.9 최신으로 업데이트해도 같은 현상입니다.

     

    위 방법을 적용해 보아도 게시판 줄바꿈 문제는 같은 현상이고, 2번만 다른 결과입니다. 

     

    워드프레스 계정과 FTP 접속 정보를 메일로 보내드리오니,

    확인 부탁드리겠습니다 ㅠㅠ

  • 안녕하세요.

    1. <br> 태그가 적용되지 않는 것은 에러는 아닙니다.

    워드프레스 내장 에디터에서 <br> 태그를 사용하지 않기 때문에 테마나 플러그인 쪽의 문제는 아닙니다.

    워드프레스 내장 에디터에서 엔터를 눌렀을 때 <br> 태그가 삭제되고 &nbsp;가 추가되도록 워드프레스에서 세팅이 되어있습니다.

    최종 화면에 내용이 출력될 때 nl2br 혹은 wpautop 함수로 <br> 태그를 추가하고 있습니다.

     

    2. 미디어 추가 버튼은 테마 때문에 동작이 안 되는 듯합니다.

    워드프레스 관리자 -> KBoard -> 게시판 목록 -> 게시판 선택 -> 고급설정 페이지에서

    아이프레임 보기 설정을 활성화해서 확인해보시겠어요?

    고맙습니다.

코스모스팜 회원관리