코스모스팜 스레드

우커머스 다운그레이드 후 상품 편집이 안 됩니다.

안녕하세요.

궁금한 것이 있어 질문 드립니다.

워드프레스 우커머스를 사용 중인데, 얼마 전 3.x.x 버전으로 업그레이드 후 약간 문제가 있어

다시 2.x.x 버전으로 다운그레이드 하였습니다.

그런데 3 버전에서 작성하였던 상품 페이지의 내용을 수정 후 업데이트 버튼을 눌러도 진행이 안됩니다.

그리고 상품 편집으로 들어가면 상단에 아래와 같은 메시지가 뜹니다.

---

브라우저에서 이 글의 백업은 아래의 버전과 차이가 납니다.백업을 복구하기

이것은 현재의 편집기 콘텐츠를 최근 백업 버전으로 교체합니다. 이전 콘텐츠를 다시 가져오거나 복구된 버전으로 돌아가려면 편집기에서 되돌리기와 다시하기를 실행할 수 있습니다.

---

위 메시지의 '백업을 복구하기' 버튼을 클릭해도 상품 편집 후 업데이트가 되지 않습니다.

 

그래서 혹시,

우커머스를 아래 버전으로 다운그레이드 하면 상위버전에서 작성한 상품은 편집이 불가능한 것인가요?

그렇다면 그런 상품은 삭제 후 다시 작성해야 된다는건데...ㅠ

완전 노가다를 해야 되는지..ㅠ

알려주시면 감사하겠습니다.

답변 기다리겠습니다.

무제한으로 웹사이트를 만드세요. (코스모스팜 무제한 라이센스)
무제한으로 웹사이트를 만드세요. (코스모스팜 무제한 라이센스)
  • 도움을 드리고 싶지만 우커머스를 다운그레이드 해본 경험이 없다 보니 답변드리기가 어렵군요^^;;

    상품 데이터 저장 형식이 버전 별로 서로 다르다면 강제로 수정하다간 정보 자체가 사라질 수 있기 때문에 조심하셔야 하고,

    또 프로그램이 예상치 못한 오류가 날 가능성이 매우 높습니다.

    에러를 최소화하기 위해서 KBoard는 프로그램 코드가 변경되어도 데이터 부분은 거의 변경하지 않고 업데이트를 진행하고 있습니다.

     

    크롬 브라우저의 개발자 도구(F12키)를 실행시키고 콘솔(Console)에 어떠한 메시지가 나오는지도 체크해보세요.

    자바스크립트 오류가 발생되면 빨간색으로 에러 메시지가 나옵니다.

     

    웹호스팅 이용하고 계신다면 매일매일 백업되는 자료가 있을 겁니다.

    우커머스 업데이트 전으로 복원을 해보시는 게 최선이 아닐까 합니다.

    아니면 우커머스를 업데이트하고 다른 플러그인과 테마도 모두 업데이트해서 사용해보시면 어떨까 합니다.

    업데이트는 보안 때문이라도 하시는 게 좋기 때문입니다.

    잘 해결되시길 바랍니다.

  • 답변 감사합니다. ^^

    우커머스를 업데이트할 때 다른 여러 플러그인들도 함께 업데이트를 하였는데

    호환에 문제가 있는지 어떤 하나의 플러그인이 작동을 하지 않았고, 검색해 보니 우커머스의 버전 첫 자리가 2에서 3으로 바뀔때는

    대대적인 변화가 있다고 하더라고요. 그래서 다운그레이드 후 아예 전체적으로 업데이트 전으로 가는 것이 좋을거 같아

    호스팅 업체를 통해 복원을 했었습니다.

    그러다 오늘 상위 버전으로 작성했던 상품을 수정하려고 하니, 수정 후 업데이트를 클릭해도 진행이 안 되서 

    위와 같은 질문을 드렸습니다.

    왠지 수정 안 되는 상품들은 삭제하고 다시 올려야 될 거 같네요.. 흑. ㅠ

     

    제가 이번 일을 겪으면서 플러그인 업데이트 하는 것이 굉장히 조심스러워 지는데, 

    운영에 문제가 없다면 모든 플러그인을 업데이트 하지 않고 그냥 쭉 사용하려고 하는데요.

    (쇼핑몰이라 업데이트 후 문제가 생기면 바로바로 대응하기가 힘들어서요.. 개발자가 아니라서..ㅠ)

    이렇게 사용하면 보안에 큰 위험이 있을까요?

    그래서 테마도 업데이트 안 하고 있는데.....ㅎㅎ (갑자기 뭔가 바뀌고 안 되면 대응하기 힘들어서요 ㅠ)

    전문가의 의견을 듣고 싶습니다. ^^

    어떻게 하는게 좋을까요?

  • 보통 웹호스팅에 보시면 데이터베이스(DB)와 파일(웹하드) 백업이 따로 될 겁니다.

    한쪽만 복원하시면 안 되고 모두 같은 날짜로 복원하셔야 안전합니다.

    우커머스 같은 플러그인이 업데이트되면 보통 데이터베이스와 파일 모두 변경되기 때문입니다.

     

    그리고 업데이트를 안 한다고 해서 반드시 보안에 아주 엄청난 구멍이 생기는 것은 아닙니다.

    오히려 새로운 버전에서 새로운 구멍이 생기는 경우도 있죠.

    웹호스팅 이용하시면 웹호스팅 업체에서도 자체적으로 방화벽등 보안 서비스가 기본으로 있을 겁니다.

    그렇기 때문에 보통의 경우는 안심하셔도 됩니다.

    아주 가끔 큰 구멍이 발견되어 업데이트를 하라는 기사나 소식을 접했을 경우라면 업데이트를 해주시는 게 좋겠지요.

     

    혹시 오해하실까 봐 추가로 말씀드리자면,

    워드프레스가 특히 보안에 취약한 것은 아닙니다.

    엄청난 사용자를 보유한 윈도우도 거의 매일매일 업데이트가 이뤄지듯이

    워드프레스도 사용자가 많기 때문에 공격에 대상이 될 가능성이 높기 때문에 보안에 주의하라는 말씀입니다 ㅎㅎ

  • 아, 그렇군요.

    스레드봇님, 친절한 답변 감사합니다. ^^

    일단 업데이트 하지 않고 써야겠네요. ㅎㅎ

    수정 안되는 상품들은 전부 삭제하고 다시 올리는 노가다를 해야겠네요. ㅠ

    감사합니다.

이미지 사진은 imgur에 업로드한 뒤 링크 걸어주세요.
무제한으로 웹사이트를 만드세요. (코스모스팜 무제한 라이센스)